Булево что это такое


Примитивный тип Булево

Многие, кто только начинает изучать программирование, впервые сталкиваются с новым для себя примитивным типом булево. Еще его по-другому называют логический тип.  Данный тип назван в честь английского математика Джорджа Буля, который изучал вопросы математической логики.

Прежде чем начать изучать этот примитивный тип, узнаем вообще, что такое булевы или логические выражения.

Булевы выражения это что-то типа вопроса, на который должен быть однозначные ответ или да, или нет.

5 < 7 —  Да;

5 = 8 – Нет;

4 > 9 – Нет.

Так же могу и быть более сложные вопросы:

Кнопка нажата – да;

Или

Кнопка нажата – нет;

Булевы выражения используются во всех условных переходах:

Если тогда

//операторы

ИначеЕсли тогда

//операторы

КонецЕсли;

В языке программирования 1С переменную с примитивным типом Булево можно задать явно:

А = Истина;

Б = Ложь;

Где Истина и Ложь единственные значения, которые может принимать примитивный тип Булево.

Истина – значит, что какое-то утверждение соответствует действительности (Ответ  — Да).

Ложь – значить,  что какое-то утверждение, наоборот, не соответствует действительности (Ответ –Нет).

Так же переменные с типом булево могут быть заданы с помощью какого-либо логического выражения. Например:

А = 5 < 7;

Б = 6 > 9;

В этом случае, в переменой А будет значение Истина, а в переменной типа Б – ложь;

В языке программирования 1С над переменными типа булево можно осуществлять различные операции.

Например:

А = 5 < 7;

Б = 6 > 9;

В = А И Б;

С = А ИЛИ Б;

Д = Не А;

Всего их три – И, ИЛИ и НЕ.

Понять функциональность этих операций помогут следующие таблицы

Операция НЕ

А Б
Истина Ложь
Ложь Истина

Операция И

С = А И Б А Б
Истина Истина Истина
Ложь Ложь Истина
Ложь Истина Ложь
Ложь Ложь Ложь

Операция ИЛИ

С = А ИЛИ Б А Б
Истина Истина Истина
Истина Ложь Истина
Истина Истина Ложь
Ложь Ложь Ложь

А можно ли выполнять данные операции подряд?

Да можно, данные операции будут выполняться слева направо. И иметь следующий уровень старшинства:

Первый: в первую очередь выполняются операции в скобках

Второй: Операция НЕ

Третий: Операция И

Четвертый: Операция ИЛИ.

Чтобы не путаться в операциях, я советую Вам использовать скобки, где только возможно.

Например:

А = Ложь;

Б = Истина;

С = Ложь;

Д = А и С или Б;

В данном случае сначала будет работать операция И между А и С.

Смотрим таблицу А – Ложь, С – Ложь, результат А И С будет Ложь.

Следующим шагом будет выполнение операции ИЛИ между Ложью (Результат предыдущей операции) и значением Б, которое Истина.

Результат будет Истина.

А если нам надо, чтобы прошла сначала операция ИЛИ между С и Б, а потом только операция И между А и тем, что получилось, то для этого необходимо использовать скобки.

Смотрим:

А = Ложь;

Б = Истина;

С = Ложь;

Д = А и (С или Б);

Результат будет диаметрально противоположный. Почему? Сейчас разберем. Благодаря скобкам сначала выполняется операция и между С и Б, т.к. С — Ложь, а Б – Истина, результат будет Истина. Потом между значением А (которое Ложь) и значением Истина (результатом предыдущей операции) выполняется операция И. Результат будет Ложь.

Многие начинающие программисты не совсем до конца понимают принципы взаимодействия между переменными типа Булево.  Помочь в этом сможет только практика. А практики с переменными типа Булево достаточно в моем задачнике к книге «Программировать в 1С за 11 шагов»

Изучайте основы конфигурирования в 1С и учитесь программировать в «1С: Предприятии» с помощью моих книг: «Программировать в 1С за 11 шагов» и «Основы разработки в 1С: Такси»

Книга «Программировать в 1С за 11 шагов»

Изучайте программирование в 1С в месте с моей книги «Программировать в 1С за 11 шагов»

  1. Книга написана понятным и простым языком — для новичка.
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Научитесь понимать архитектуру 1С;
  4. Станете писать код на языке 1С;
  5. Освоите основные приемы программирования;
  6. Закрепите полученные знания при помощи задачника;

Книга «Основы разработки в 1С: Такси»

Отличное пособие по разработке в управляемом приложении 1С, как для начинающих разработчиков, так и для опытных программистов.

  1. Очень доступный и понятный язык изложения
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Поймете идеологию управляемого приложения 1С
  4. Узнаете, как разрабатывать управляемое приложение;
  5. Научитесь разрабатывать управляемые формы 1С;
  6. Сможете работать с основными и нужными элементами управляемых форм
  7. Программирование под управляемым приложением станет понятным

Промо-код на скидку в 15% — 48PVXHeYu

Если Вам помог этот урок решить какую-нибудь проблему, понравился или оказался полезен, то Вы можете поддержать мой проект, перечислив любую сумму:

можно оплатить вручную:

Яндекс.Деньги — 410012882996301 Web Money — R955262494655

Вступайте в мои группы:

Вконтакте: https://vk.com/1c_prosto Фейсбуке: https://www.facebook.com/groups/922972144448119/ ОК: http://ok.ru/group/52970839015518 Твиттер: https://twitter.com/signum2009

www.1s-up.ru

Условные операции 1С и булево 1С

Значение Булево 1С — это значение Истина или Ложь. В числовом выражении Ложь это ноль, а Истина — число больше нуля (обычно единица).

Выражение (операция) Булево 1С — это математическое выражение, результатов которого является значение типа Булево 1С, например: a = 0+1; b = 2-1; x = (a = b); //x = Истина

Далее — подробнее о условных операциях 1С, значениях и выражениях булево 1С.

Условная операция 1С ЕСЛИ выглядит следующим образом: Если ОПЕРАЦИЯ-БУЛЕВО Тогда      //действия1… ИначеЕсли ОПЕРАЦИЯ-БУЛЕВО Тогда      //действия2… Иначе      //действия3… КонецЕсли;

Булево 1С — это результат вычисления со значениями Истина или Ложь, например: Массив1 = Новый СписокЗначений(); Если Массив1.Количество() > 0 Тогда      //действия…

КонецЕсли;

//другой вариант, полностью аналогичный Если НЕ Массив1.Количество() = 0 Тогда      //действия… КонецЕсли;

Многие функции/методы объектов возвращают успешность выполнения операции как булево 1С, например: Запрос = Новый Запрос(); Выборка = Запрос.Выполнить().Выбрать(); Если Выборка.Следующий() Тогда      //действия… КонецЕсли;

В условной операции 1С можно объединять несколько условий с использованием И и ИЛИ: Массив1 = Новый СписокЗначений(); Если (Массив1.Количество() > 0 и Массив1.Количество() < 10) или Массив.Количество() > 100 Тогда      //действия… КонецЕсли;

Условия булево 1С можно использовать непосредственно в коде программы: Переменная1 = 5; флгРезультат = (Переменная1 = 2 + 3); //флгРезультат будет равен ИСТИНА

В условной операции 1С оператор ЕСЛИ ИНАЧЕ ТОГДА можно заменить более кратким выражением. Следующие два варианта равны:

У реквизитов объектов (справочников, документов и т.п.) есть возможность установить тип булево 1С. Также можно создать переменную булево 1С, например: флгВыполнено = Истина;

Далее, в условиях ЕСЛИ, можно писать равнозначно двумя способами: //вариант 1 Если флгВыполнено = Истина Тогда      //делаем что-то

КонецЕсли;

//вариант 2 Если флгВыполнено Тогда      //делаем что-то КонецЕсли;

Второй вариант таит в себе следующую «неприятность»:

howknow1c.ru

Булева алгебра - это... Что такое Булева алгебра?

Эта статья об алгебраической системе. О разделе математической логики, изучающем высказывания и операции над ними, см. Алгебра логики.

Булевой алгеброй[1][2][3] называется непустое множество A с двумя бинарными операциями (аналог конъюнкции), (аналог дизъюнкции), унарной операцией (аналог отрицания) и двумя выделенными элементами: 0 (или Ложь) и 1 (или Истина) такими, что для всех a, b и c из множества A верны следующие аксиомы:

Первые три аксиомы означают, что (A, , ) является решёткой. Таким образом, булева алгебра может быть определена как дистрибутивная решётка, в которой выполнены две последние аксиомы. Структура, в которой выполняются все аксиомы, кроме предпоследней, называется псевдобулевой алгеброй.

Некоторые свойства

Из аксиом видно, что наименьшим элементом является 0, наибольшим является 1, а дополнение ¬a любого элемента a однозначно определено. Для всех a и b из A верны также следующие равенства:

Основные тождества

В данном разделе повторяются свойства и аксиомы, описанные выше с добавлением ещё нескольких.

Сводная таблица свойств и аксиом, описанных выше:

См. также Алгебра логики

Примеры

  • Самая простая нетривиальная булева алгебра содержит всего два элемента, 0 и 1, а действия в ней определяются следующей таблицей:
  • Эта булева алгебра наиболее часто используется в логике, так как является точной моделью классического исчисления высказываний. В этом случае 0 называют ложью, 1 — истиной. Выражения, содержащие булевы операции и переменные, представляют собой высказывательные формы.
  • Алгебра Линденбаума — Тарского (фактормножество всех утверждений по отношению равносильности в данном исчислении с соответствующими операциями) какого-либо исчисления высказываний является булевой алгеброй. В этом случае истинностная оценка формул исчисления является гомоморфизмом алгебры Линденбаума — Тарского в двухэлементную булеву алгебру.
  • Множество всех подмножеств данного множества S образует булеву алгебру относительно операций ∨ := ∪ (объединение), ∧ := ∩ (пересечение) и унарной операции дополнения. Наименьший элемент здесь — пустое множество, а наибольший — всё S.
  • Если R — произвольное кольцо, то на нём можно определить множество центральных идемпотентов так: A = { e ∈ R : e² = e, ex = xe, ∀x ∈ R }, тогда множество A будет булевой алгеброй с операциями e ∨ f := e + f − ef и e ∧ f := ef.

Принцип двойственности

В булевых алгебрах существуют двойственные утверждения, они либо одновременно верны, либо одновременно неверны. Именно, если в формуле, которая верна в некоторой булевой алгебре, поменять все конъюнкции на дизъюнкции, 0 на 1, ≤ на ≥ и наоборот, то получится формула, также истинная в этой булевой алгебре. Это следует из симметричности аксиом относительно таких замен.

Представления булевых алгебр

Можно доказать, что любая конечная булева алгебра изоморфна булевой алгебре всех подмножеств какого-то множества. Отсюда следует, что количество элементов в любой конечной булевой алгебре будет степенью двойки.

Знаменитая теорема Стоуна утверждает, что любая булева алгебра изоморфна булевой алгебре всех открыто-замкнутых множеств какого-то компактного вполне несвязного хаусдорфова топологического пространства.

Аксиоматизация

В 1933 г. американский математик Хантингтон предложил следующую аксиоматизацию для булевых алгебр:

  1. Аксиома коммутативности: x + y = y + x.
  2. Аксиома ассоциативности: (x + y) + z = x + (y + z).
  3. Уравнение Хантингтона: n(n(x) + y) + n(n(x) + n(y)) = x.

Здесь использованы обозначения Хантингтона: + означает дизъюнкцию, n — отрицание.

Герберт Роббинс поставил следующий вопрос: можно ли сократить последнюю аксиому так, как написано ниже, то есть будет ли определённая выписанными ниже аксиомами структура булевой алгеброй?

Аксиоматизация алгебры Роббинса:

  1. Аксиома коммутативности: x + y = y + x.
  2. Аксиома ассоциативности: (x + y) + z = x + (y + z).
  3. Уравнение Роббинса: n(n(x + y') + n(x + n(y))) = x.

Этот вопрос оставался открытым с 30-х годов и был любимым вопросом Тарского и его учеников.

В 1996 г. Вильям МакКьюн, используя некоторые полученные до него результаты, дал утвердительный ответ на этот вопрос. Таким образом, любая алгебра Роббинса является булевой алгеброй.

См. также

  • Алгебра логики
  • Булева функция
  • Битовые операции

Примечания

partners.academic.ru

Булева алгебра - это... Что такое Булева алгебра?

  • БУЛЕВА АЛГЕБРА —     БУЛЕВА АЛГЕБРА см. Алгебра логики. Новая философская энциклопедия: В 4 тт. М.: Мысль. Под редакцией В. С. Стёпина. 2001 …   Философская энциклопедия

  • БУЛЕВА АЛГЕБРА — Boolean algebra От Дж.Буль английский математик 1815 1864 Раздел математической логики, изучающий высказывания и операции над ними. Наиболее известными операциями булевой алгебры являются: конъюнкция, дизъюнкция, импликация, эквивалентность,… …   Словарь бизнес-терминов

  • БУЛЕВА АЛГЕБРА — БУЛЕВА АЛГЕБРА, область математики, содержащая правила обращения с множествами, а также с логическими утверждениями типа «и», «или». Например, в Булевой алгебре выражение ху означает «х и у», а х+у это «х или у». Данный принцип широко применяется …   Научно-технический энциклопедический словарь

  • Булева алгебра — Эта статья об алгебраической системе. О разделе математической логики, изучающем высказывания и операции над ними, см. Алгебра логики. Булевой алгеброй[1][2][3] называется непустое множество A с двумя бинарными операциями (аналог конъюнкции),… …   Википедия

  • булева алгебра — Boolean algebra statusas T sritis automatika atitikmenys: angl. Boolean algebra vok. Boolesche Algebra, f rus. булева алгебра, f pranc. algèbre de Boole, f ryšiai: sinonimas – Bulio algebra …   Automatikos terminų žodynas

  • БУЛЕВА АЛГЕБРА — булева решетк а, частично упорядоченное множество специального вида. Б. а. наз. дистрибутивная решетка (дистрибутивная структура), имеющая наибольший элемент 1 единицу Б. а., наименьший элемент 0 нуль Б. а. и содержащая вместе с каждым своим… …   Математическая энциклопедия

  • Булева алгебра — алгебра, в которой каждая переменная может принимать одно из двух значений: «истина» или «ложь». Операции над переменными в булевой алгебре называются логическими операциями. Правила выполнения логических операций удобны для преобразования… …   Начала современного естествознания

  • БУЛЕВА АЛГЕБРА — Названная по имени ее создателя, английского математика Джорджа Буля, система операций с символами, которая использует алгебраические процедуры, но независимо от определенных математических интерпретаций. Булева логика, или калькуляция (как она… …   Толковый словарь по психологии

  • Булева алгебра — (араб.) – система алгебраических операций с символами, названная в честь Д. Буля, одного из её создателей. Также называется калькуляцией (лат. calсulatio – счёт, подсчёт). Интересно, что Д. Буль рассматривал свою работу как представление основных …   Энциклопедический словарь по психологии и педагогике

  • булева алгебра элементарных логических операции — — [http://slovarionline.ru/anglo russkiy slovar neftegazovoy promyishlennosti/] Тематики нефтегазовая промышленность EN Boolean algebra …   Справочник технического переводчика

dic.academic.ru


Смотрите также

Календарь

ПНВТСРЧТПТСБВС
     12
3456789
10111213141516
17181920212223
24252627282930
31      

Мы в Соцсетях

 

vklog square facebook 512 twitter icon Livejournal icon
square linkedin 512 20150213095025Одноклассники Blogger.svg rfgoogle